Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Doppler in auch divergierenden Zeilen auflisten


Aufgabe
Während eines Zeitraums werden 2 Messwertreihen durchgeführt. Beide nicht zu jedem Termin und beide nicht unbedingt an übereinstimmenden Terminen.
Es sollen jetzt nur die Meßwerte der identischen Termine aufgelistet werden.

       A               B               C               D               E               F               G               H       
1 Datum 1  Wert 1  Datum 2  Wert 2    Datum 1+2  Wert 1  Wert 2  
2 01.06.2010  02.06.2010    02.06.2010  8  
3 02.06.2010  03.06.2010    05.06.2010  7  
4 04.06.2010  05.06.2010    07.06.2010  7  
5 05.06.2010  06.06.2010    12.06.2010  9  
6 07.06.2010  07.06.2010    20.06.2010  5  
7 08.06.2010  11.06.2010    24.06.2010  3  
8 09.06.2010  12.06.2010    26.06.2010  9  
9 12.06.2010  20.06.2010         
10 19.06.2010  23.06.2010  10         
11 20.06.2010  24.06.2010         
12 21.06.2010  25.06.2010         
13 24.06.2010  26.06.2010         
14 26.06.2010  30.06.2010         
15 27.06.2010             
16 29.06.2010             



Lösung
in F2 steht:
{=WENN(ZEILE(A1)>SUMME(ZÄHLENWENN(A$2:A$99;C$2:C$99));"";INDEX(C:C;KKLEINSTE(WENN(ZÄHLENWENN(A$2:A$99;C$2:C$99);ZEILE(A$2:A$99));ZEILE(A1))))}

in G2 und H2:
=WENN(F2="";"";INDEX(B:B;VERGLEICH(F2;A:A;0)))
=WENN(F2="";"";INDEX(D:D;VERGLEICH(F2;C:C;0)))

alle 3 runterkopieren