Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Duplikate mehrerer Spalten bzw. Datensätze markieren


Aufgabe
Wenn sich die Duplikatssuche auf mehrere Spalten bezieht, wird's etwas komplizierter:

       A               B               C               D       
1 Walter   
2 5  Walter  x   
3 Andy   
4 Walter   
5 Jens   
6 10  Walter   
7 Jens   
8 Walter   
9 8  Andy  x   
10 5  Walter  x  Duplikat  
11 Andy   
12 8  Andy  x  Duplikat  
13 Andy   
14 Walter   
15 Walter   

Siehe dazu auch Nr. 257

Lösung
Datensätze: Spalte A bis C

In D1 steht:
{=WENN(VERGLEICH(A1&B1&C1;A$1:A$100&B$1:B$100&C$1:C$100;0)=ZEILE();"";"Duplikat")}

Diese Formel runterkopieren.


Ergänzung vom 15.12.2005
Hilfsspaltenlösung bei großem Datenbestand

Runterkopierte Array-Formeln sind bei großen Datenbeständen schnarchlangsam.
Da hilft nur eine (arraylose) Hilfsspaltenlösung.

schreibe in D1:
=A1&B1&C1
und in E1:
=WENN(ZÄHLENWENN(D$1:D1;D1)>1;"Duplikat";"")
beide runterkopieren