Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Eine Diagonale addieren


Aufgabe
Du willst in einem Bereich die Diagonale addieren also z.B. A1+B2+C3+D4 usw.

       A               B               C               D               E               F               G               H               I               J       
1 593  182  744  770  646  811  528  514  675  512  
2 847  329  432  259  963  670  459  662  452  521  
3 314  990  809  401  229  247  919  577  912  585  
4 764  840  577  144  818  329  468  978  811  518  
5 251  835  990  972  762  342  627  452  965  845  
6 495  399  651  535  821  714  165  944  619  402  
7 210  684  641  894  563  864  593  916  823  995  
8 659  948  331  467  414  328  393  933  360  505  
9 940  166  108  829  933  120  882  692  200  857  
10 304  288  481  819  172  544  848  302  564  909  
11                    
12 Summe  5986                 

Lösung
Diagonale: A1:j10
=SUMMENPRODUKT(N(INDIREKT(ADRESSE(ZEILE(1:99);ZEILE(1:99)))))

die Diagonal-Summe ausgehend von B3 also B3+C4+D5+E6 etc. lautet:
=SUMMENPRODUKT(N(INDIREKT(ADRESSE(ZEILE(3:99);ZEILE(2:98)))))

Bei ADRESSE also erst Zeile und dann Spalte ansprechen; - im Gegensatz zur üblichen Zellbezeichnung z.B. B3 ist ADRESSE(3;2)

Erläuterung
Seit Excel-2010 gibt es die Funktion MEINHEIT (Einheitsmatrix) - damit:
=SUMMENPRODUKT((A1:J10)*MEINHEIT(10))
bzw.
=SUMMENPRODUKT((B3:I10)*MEINHEIT(8))