Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Eine Fußball-Tabelle aus Punkten und Tordifferenz generieren


Aufgabe
Es liegt eine alphabetische Vereinsliste mit den jeweils erzielten Punkten und der Tordifferenz vor. Hieraus soll ohne zu sortieren automatisch die Tabelle generiert werden.




Lösung
In E2 steht 1
In E3 steht:
=WENN(RUNDEN(G3;5)=RUNDEN(G2;5);"";ZEILE()-1)

In F2 steht:
{=INDEX(A:A;VERGLEICH(G2;B$1:B$100+(C$1:C$100)/1000-ZEILE($1:$100)/10000000;0))}

In G2 steht:
{=KGRÖSSTE(WENN($A$2:$A$100<>"";(B$2:B$100+C$2:C$100/1000-ZEILE($2:$100)/10000000));ZEILE()-1)}

In H2 steht:
=INDEX(C:C;VERGLEICH(F2;A:A;0))

E3 und F2 bis H2 runterkopieren.

Soll die Tabelle noch weiter verfeinert werden und bei Punkt- und Tordifferenzgleichheit die Anzahl der erzielten Tore bewertet werden und diese stehen in Spalte D, lautet die Formel in F2
{=INDEX(A:A;VERGLEICH(G2;B$1:B$100+C$1:C$100/1000+D$1:D$100/100000-ZEILE($1:$100)/10000000;0))}
und die in G2
{=KGRÖSSTE(B$2:B$100+C$2:C$100/1000+D$2:D$100/100000-ZEILE($2:$100)/10000000;ZEILE()-1)}