Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Eine Monatszahl in Monate und Jahre aufteilen


Aufgabe
Eine bestimmte Anzahl an Monaten soll in Jahre und Monate aufgeteilt werden

       A               B       
1 11  11 Monate  
2 2341  195 Jahre, 1 Monat  
3 360  30 Jahre  
4 15  1 Jahr, 3 Monate 

Lösung
Zahl steht in A1

=WENN(A1>=12;KÜRZEN(A1/12)&" Jahr"&WENN(KÜRZEN(A1/12)>1;"e";"");"")&WENN(REST(A1;12)>0;WENN(A1>=12;", ";"")&REST(A1;12)&" Monat"&WENN(REST(A1;12)>1;"e";"");"")

Eine Aufteilung von Tagen in Wochen und Tage, geht so:

=WENN(A1>=7;KÜRZEN(A1/7)&" Woche"&WENN(KÜRZEN(A1/7)>1;"n";"");"")&WENN(REST(A1;7);WENN(A1>=7;", ";"")&REST(A1;7)&" Tag"&WENN(REST(A1;7)>1;"e";"");"")