Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Eine Tabelle von unten nach oben kehren (spiegeln)


Aufgabe
Eine Tabelle soll automatisch von unten nach oben gekehrt werden, so daß der unterste Eintrag an erster und der oberste an letzter Stelle steht.


Lösung
In Zelle A1 der neuen Tabelle:
=WENN(ANZAHL2(Tabelle1!A:A)+1-ZEILE(A1)<1;"";INDIREKT("Tabelle1!A"&ANZAHL2(Tabelle1!A:A)+1-ZEILE(A1)))

Können auch Leerzellen vorkommen, dann:
=WENN(VERWEIS(2;1/(Tabelle1!A$1:A$500<>"");ZEILE(A$1:A$500))+1-ZEILE(A1)<1;"";INDIREKT("Tabelle1!A"&VERWEIS(2;1/(Tabelle1!A$1:A$500<>"");ZEILE(A$1:A$500))+1-ZEILE(A1)))
oder:
=WENN(SUMMENPRODUKT(ISTLEER(A1:A99)*1)>98;"";INDEX(A:A;VERWEIS(2;1/(A$1:A$999<>"");ZEILE(A$1:A$999))+1-ZEILE(A1)))
runterkopieren

Besteht die Tabelle aus mehreren Spalten (mit Leerzellen), dann in A1 die Array-Formel:
{=WENN(MAX((Tabelle1!$A$1:$D$500<>"")*ZEILE($1:$500))+1-ZEILE(A1)<1;"";BEREICH.VERSCHIEBEN(Tabelle1!A$1;MAX((Tabelle1!$A$1:$D$500<>"")*ZEILE($1:$500))-ZEILE(A1);;;))}
nach rechts und nach unten kopieren


Erläuterung
Extras / Optionen / Ansicht: Nullwerte deaktivieren, da bei Leerzellen 0 angezeigt würde.