Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Eine quadratische Matrix automatisch aufsteigend sortieren


Aufgabe
Wie der Titel schon sagt.
Lösung
Es kann eine Matrix bis zum Grad 10 (A1 bis J10) sortiert werden.
Die Matrix muß quadratisch sein.

       A               B               C               D               E               F       
1 5  
2 10  -7  18  17  5  
3 57  
4 41  100  5  
5 10  29  93  5  
6 10  20  -18  5  
7            
8            
9            
10            
11 6           
12 -18  -7  0  2  5  5  
13 5  5  5  5  6  6  
14 6  6  7  7  7  7  
15 7  8  8  8  9  9  
16 9  10  10  10  17  18  
17 20  29  41  57  93  100 


In A11 steht der Grad der Matrix:
=MIN(ANZAHL(A1:A10);ANZAHL(A1:J1))

In A12 steht:
=WENN(ODER(SPALTE()>$A$11;ZEILE()-11>$A$11);"";KKLEINSTE($A$1:INDIREKT(ADRESSE($A$11;$A$11));(ZEILE()-12)*10+SPALTE()-(10-$A$11)*(ZEILE()-12)))
bis J21 kopieren

Soll absteigend sortiert werden, dann in dieser Formel statt KKLEINSTE: KGRÖSSTE