Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: Einen Betrag linear auf mehrere Teilbeträge aufteilen


Aufgabe
Sie planen ein Gesamtbudget über einen Betrag x und möchten diesen linear auf 12 Kostenstellen runterbrechen. Die Beträge sollen Cent-genau aufgeteilt werden und es dürfen keine Rundungsdifferenzen übrig bleiben, d.h. die Summe der 12 Kostenstellen muß wieder exakt dem Gesamtbudget entsprechen. Außerdem soll möglichst gleichmäßig verteilt werden, entstehende Rundungsdifferenzen dürfen also nicht über eine einzelne Kostenstelle ausgebügelt werden.

       A               B       
1 Gesamtplanung:  1.700  
2    
3 Kostenstellen:   
4 Kostenstelle01  141,67  
5 Kostenstelle02  141,66  
6 Kostenstelle03  141,67  
7 Kostenstelle04  141,67  
8 Kostenstelle05  141,66  
9 Kostenstelle06  141,67  
10 Kostenstelle07  141,67  
11 Kostenstelle08  141,66  
12 Kostenstelle09  141,67  
13 Kostenstelle10  141,67  
14 Kostenstelle11  141,66  
15 Kostenstelle12  141,67 

141,67 mal 12 wären 1.700,04

Lösung
In B1 steht der Gesamtbetrag

B4:=RUNDEN(B$1/ANZAHL2($A$4:$A$15)*ANZAHL2($A$4:A4);2)

B5:=RUNDEN(B$1/ANZAHL2($A$4:$A$15)*ANZAHL2($A$4:A5);2)-SUMME(B$4:B4)

B5 wird kopiert bis B15.

Soll ganzzahlig aufgeteilt werden dann:

B4:=RUNDEN(B$1/ANZAHL2($A$4:$A$15)*ANZAHL2($A$4:A4);0)

B5:=RUNDEN(B$1/ANZAHL2($A$4:$A$15)*ANZAHL2($A$4:A5);0)-SUMME(B$4:B4)