Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Iteration - BEITRAG: Einen Text drehen oder Buchstaben von Ziffern trennen


Aufgabe
Ein Text soll von rechts nach links dargestellt werden.

- Ohne Iteration ist das nur mit Ziffern möglich (siehe Formel Nr 244)

Aus einem Text sollen Ziffern und Textzeichen getrennt werden.

- Nur den Text darzustellen geht auch mit Formel Nr. 174

- Nur die Ziffern darzustellen geht normal nur für Ziffern bis Länge 15. Siehe dazu Formel Nr. 103

       A               B               C               D               E       
1 String  Zähler  Ziffern  Textzeichen  von rechts nach links  
2 123Jens Fleckenstein456  100  123456  Jens Fleckenstein  654nietsnekcelF sneJ321  
3 Andreas12 Dusin64  100  1264  Andreas Dusin  46nisuD 21saerdnA 

Lösung

Wähle Extras>Optionen>Berechnen>Iteration>Maximale Iterationszahl:100
(für längere Strings erhöhen)

In A2 steht der String

in B2 steht
=WENN(B2=100;1;B2+1)

in C2 steht (Ziffern)
=WENN(B2=1;"";WENN(B2-1>LÄNGE(A2);C2;WENN(ISTZAHL(TEIL(A2;B2-1;1)*1);C2&TEIL(A2;B2-1;1);C2)))

in D2 steht (Text)
=WENN(B2=1;"";WENN(B2-1>LÄNGE(A2);D2;WENN(NICHT(ISTZAHL(TEIL(A2;B2-1;1)*1));D2&TEIL(A2;B2-1;1);D2)))

in E2 steht (umgedrehter String)
=WENN(B2=1;"";WENN(B2-1>LÄNGE(A2);E2;TEIL(A2;B2-1;1)&E2))