Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Einträge in gefilterter Liste ohne Duplikate zählen


Aufgabe
Eine Liste ist nach irgendeiner Spalte gefiltert.
Nun sollen die sichtbaren Einträge einer Spalte ohne Duplikate gezählt werden




Lösung
Die Einträge, die gezählt werden sollen, stehen in Spalte B2:B??

{=SUMME((VERGLEICH(WENN(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(2:100)));B2:B100);WENN(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(2:100)));B2:B100);0)=ZEILE(1:99))*(WENN(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(2:100)));A2:A100)<>FALSCH))}

Handelt es sich in Spalte B nur um Zahlen, funktioniert's ohne Array mit:
=SUMME((HÄUFIGKEIT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(2:100)))*(B2:B100);TEILERGEBNIS(3;INDIREKT("A"&ZEILE(2:100)))*(B2:B100))>0)*1)-1
Akzeptiert auch mehrere Spalten (B2:E100)