Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Enthält eine bestimmte Zelle ein Datum oder nicht


Aufgabe
Wie kann ermittelt werden, ob in einer bestimmten Zelle ein Datum enthalten ist, oder nicht ?

       A               B       
1 Beispiele:   
2 01. Jan   Datum  
3 '1.1.01   kein Datum  
4 00.01.1900   kein Datum  
5 12. Januar 2001   Datum 




Lösung
Zelle:A1

=WENN(UND(ISTZAHL(A1);A1>0;A1<=2958465;LINKS(ZELLE("format";A1);1)="D");"Datum";"Kein Datum")

Die Formel prüft ab, ob die betreffende Zelle auf Datum formatiert ist und ob die Zahl im gültigen Bereich von 1 (1.1.1900) bis 2958465 (31.12.9999) ist.
Die Funktion ZELLE steht nur aus Gründen der Kompatibilität zu anderen Tabellenkalkulationsprogrammen zur Verfügung.
Wird der Zelle später ein anderes Format zugewiesen, mußt du die Tabelle neu berechnen, wenn das Ergebnis der ZELLE-Formel aktualisiert werden soll (F9).

Achtung: Datumsformate, die mit der Jahreszahl beginnen, z.B. JJJJ-MM-TT oder, die als Text eingegeben wurden z.B. =TEXT(B1;"TT.MM.JJJJ")
werden nicht als Datum erkannt.