Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Tabellennavigation - BEITRAG: Erste Zahl in einer Zeile oder Spalte


Aufgabe
Wie kann man die erste Zahl bzw. die Position der ersten Zahl einer Zeile oder Spalte ermitteln ?

       A               B               C               D               E               F       
1   6  5  
2          
3          
4 3           
5          
6            
7          
8          

Lösung
Spalte: A bzw. Zeile: 1

Zeile der ersten Zahl einer Spalte:
{=VERGLEICH(WAHR;ISTZAHL(A1:A999);0)}
oder:
{=MIN(WENN(ISTZAHL(A1:A999);ZEILE(1:999)))}
ohne {Arrayformel}:
=VERGLEICH(1;MMULT(1*ISTZAHL(A:A);1);0)
entsprechender Eintrag:
{=INDEX(A1:A999;VERGLEICH(WAHR;ISTZAHL(A1:A999);0))}

Spalte der ersten Zahl einer Zeile:
{=VERGLEICH(1;ISTZAHL(1:1)*1;0)}
oder:
{=MIN(WENN(ISTZAHL(1:1);SPALTE(1:1)))}
entsprechender Eintrag:
{=INDEX(1:1;VERGLEICH(1;ISTZAHL(1:1)*1;0))}