Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Tabellennavigation - BEITRAG: Erster Text in einer Zeile oder Spalte


Aufgabe
Wie kann man den ersten Text bzw. die Position des ersten Textes in einer Zeile oder Spalte ermitteln ?

       A               B               C               D               E               F       
1   q  5  
2 e           
3          
4          
5          
6            
7          
8          

Lösung
Spalte: A bzw. Zeile: 1

Zeile des ersten Textes einer Spalte:
{=VERGLEICH(1;ISTTEXT(A1:A1000)*1;0)}
oder:
{=MIN(WENN(ISTTEXT(A1:A1000);ZEILE(1:1000)))}
entsprechender Eintrag:
{=INDEX(A1:a1000;VERGLEICH(1;ISTTEXT(A1:A1000)*1;0))}

Spalte des ersten Textes einer Zeile:
{=VERGLEICH(1;ISTTEXT(1:1)*1;0)}
oder:
{=MIN(WENN(ISTTEXT(1:1);SPALTE(1:1)))}
entsprechender Eintrag:
{=INDEX(1:1;VERGLEICH(1;ISTTEXT(1:1)*1;0))}

ohne Array - höllisch einfach:
=VERGLEICH("*";A:A;0)
bzw.
=VERGLEICH("*";1:1;0)