Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Farbige Zellen zählen


Aufgabe
Es sollen alle farbigen Zellen gezählt werden - mit und ohne Bedingung. Die Zellen wurden NICHT per Bedingter Formatierung gefärbt.

Lösung
Die Anzahl - ohne Bedingung:

In A1:A100 stehen Zahlen - manche sind rot formatiert.

Einfügen - Namen - Definieren, Name: Farbe
Bezieht sich auf:

a) =ZELLE.ZUORDNEN(24;INDIREKT("ZS(-1)";)) für die Schriftfarbe
oder
b) =ZELLE.ZUORDNEN(63;INDIREKT("ZS(-1)";)) für die Hintergrundfarbe

In B1 (Hilfsspalte):
=Farbe
und runterkopieren

a) Dadurch wird die Schriftfarbe der LINKEN Nachbarzelle (ZS(-1)) ausgelesen - z.B. 3 für Rot (Blau wäre 5).

Die Anzahl der roten dann mit:
=ZÄHLENWENN(B:B;3)

Soll noch ne Bedingung eingebaut werden - z.B. nur alle Zahlen aus A1:A100, die Rot UND größer 10 sind, dann:
=SUMMENPRODUKT((A1:A100>10)*(B1:B100=3))

b) analog für die Hintergrundfarbe: Gelb z.B. ist 6 und Grau: 15

Erläuterung
Wird ein Eintrag in Spalte A nachträglich eingefärbt, wird das erst nach Neuberechnung wirksam.

Gehört eigentlich in die Kategorie "Excel4-Macrofunktionen" - wird aber in den Foren fast täglich gefragt - und unter den Macrofunktionen wird keiner suchen.