Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Iteration - BEITRAG: Flexibles Verketten von Zellen eines Bereiches


Aufgabe
Aus einer Liste soll eine beliebige Anzahl von Zellen zu einem String verkettet werden.
Die Funktion VERKETTEN kann leider nicht die Elemente eines Arrays verketten.

Beispiel in dem alle Einträge aus B verkettet werden sollen, in denen in Spalte A ein Kenner steht:

       A               B               C               D       
1   100  ceghkn  
2      
3 1  c     
4      
5 1  e     
6      
7 1  g     
8 1  h     
9      
10      
11 1  k     
12      
13      
14 1  n     
15      

Lösung
Wähle Extras>Optionen>Berechnen>Iteration>Maximale Iterationszahl:100

Die Liste geht von A1 bis A100
Für eine längere Liste muß die maximale Iterationszahl erhöht werden

In Spalte A stehen die Kenner (hier: die 1)
In Spalte B stehen die zu verkettenden Einträge.

In C1 steht
=WENN(C1=100;1;C1+1)
(ausblenden)

in D1 steht
{=WENN(C1=1;"";WENN(C1-1>ZÄHLENWENN(A:A;1);D1;D1&INDEX(B$1:B$100;KKLEINSTE(WENN(A$1:A$100=1;ZEILE($1:$100));C1-1))))}