Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Gültigkeit - BEITRAG: Formeln ohne Blattschutz vorm Überschreiben schützen


Aufgabe
Es soll verhindert werden, daß versehentlich Formeln überschrieben werden, ohne, daß der Blattschutz aktiviert wird.

Lösung
Markiere N A C H Eingabe der Formeln die entsprechenden Zellen.
Dann: Daten / Gültigkeit / Einstellungen / Zulassen: Textlänge /
Daten: zwischen / Bei Minimum und Maximum jeweils 0 (Null) eingeben.

Und bei Fehlermeldung: "Hier steht eine Formel, Du Trottel!"




Erläuterung
Einschränkungen:
Schreibt man in die Zelle ein ' wird es zugelassen, oder man schreibt die Formel rein =WENN(WAHR;""), wird dies auch akzeptiert; - und die Entf-Taste funktioniert.

Alternative Formelbedingung:
=ISTLEER(INDIREKT("ZS";0))
dann wird nichts mehr zugelassen, nur die Entf-Taste geht noch.

Eine eklatante Lücke (Hans-Peter Blum 17.03.2005):
Eine Zelle kopieren und einfügen FUNKTIONIERT in beiden Fällen!


Ergänzung vom 14.08.2005
Definiert man als Formelbedingung (für A1)
=NICHT(ZELLE("Schutz";A1))
können nur ungesperrte Zellen bechrieben werden, auch wenn der Blattschutz nicht aktiv ist.