Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Gibt es einen Artikel in einer bestimmten Größe?


Aufgabe
Es soll überprüft werden, ob eine Artikelnummer in einer bestimmten Größe vorkommt und ausgegeben werden, welche Größenbezeichnung das ist.

       A               B               C               D               E               F       
1 Artikel  Größe 1  Größe 2  Größe 3  Größe 4  Größe 5  
2 H123  24  25  48  50  52  
3 H456  23  24  25     
4 S789  40  41  42     
5 S790  39  40  41  42  43  
6            
7            
8            
9            
10   H456  25       
11   ja  Größe 3       


Lösung
In Spalte A stehen die Artikelnummern.
In B1 bis F1 die Größenbezeichnungen.
In B2 bis F?? die dazugehörigen Größen.
Die gesuchte Artikel-Nr. wird in B10 eingegeben; - die gesuchte Größe in C10.

in B11 steht:
=WENN(C11<>"";"ja";"nein")

und in C11:
=WENN(ISTZAHL(VERGLEICH(C10;INDIREKT("B"&VERGLEICH(B10;A:A;0)&":"&"F"&VERGLEICH(B10;A:A;0));0));INDIREKT(ADRESSE(1;VERGLEICH(C10;INDIREKT(VERGLEICH(B10;A:A;0)&":"&VERGLEICH(B10;A:A;0));0)));"")

Alternative/Verkürzung vom 08.11.2005
=WENN(ANZAHL(1/ZÄHLENWENN(INDEX(B2:F5;VERGLEICH(B10;A2:A5;););C10));INDEX(B1:F1;VERGLEICH(C10;INDEX(B2:F5;VERGLEICH(B10;A2:A5;););));"")