Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Gültigkeit - BEITRAG: Gültigkeitsdropdown


Aufgabe
Grundsätzlich wird bei Daten/Gültigkeit nicht zwischen Groß- und kleinschreibung unterschieden. A=a.
Unter 'Benutzerdefiniert' kann man zwischen Groß- und kleinschreibung mit der Funktion IDENTISCH unterscheiden lassen.
Wie geht das aber in Kombination mit einer Gültigkeitsliste?
Lösung
Ist die Liste kurz, kann man die zulässigen Werte direkt - semikolongetrennt - als Quelle hinterlegen:
Quelle: A;B;C
Somit sind a,b,c nicht erlaubt.

Handelt es sich um eine längere Liste (diese steht im Bereich A1:A100) und die Zelle für das Gültigkeitsdropdown ist C1, dann in C1 unter Zulassen, Liste, Quelle:

=WENN(ODER(IDENTISCH(C1;A1:A100))+(C1="");A1:A100;IV1)

wobei IV1 leer sein muss.

Wenn jetzt manuell ein Eintrag getätigt wird (was ja auch bei einem Dropdown jederzeit möglich ist), der in einer anderen Schreibweise in der Liste hinterlegt ist, ist dies nicht mehr zulässig.