Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Höhe und Datum der größten Zwischensumme


Aufgabe
In Spalte A stehen Datümer; in Spalte B Gewinne (+) und Verluste (-)
Du willst jetzt das höchste Zwischenergebnis wissen und wann dieses erreicht wurde.
Mit Hilfsspalte ab C2 =SUMME(B$2:B2) - runterkopiert und daraus dann das Maximum ist kein Problem. Ohne Hilfsspalte:

       A               B               C               D       
1 Datum  Gew. / Verl.     
2 01.01.2010  20  20  Summe gesamt  
3 02.01.2010  10  30  360  
4 03.01.2010  -70  -40   
5 04.01.2010  10  -30  höchste Zwischensumme  
6 05.01.2010  10  -20  390  
7 06.01.2010  30  10   
8 07.01.2010  150  160  am  
9 08.01.2010  -190  -30  10.01.2010  
10 09.01.2010  -30   
11 10.01.2010  420  390   
12 11.01.2010  -260  130   
13 12.01.2010  120  250   
14 13.01.2010  110  360   
15 14.01.2010  360   
16 15.01.2010  360   


Lösung
Maximum in D6:
{=MAX(TEILERGEBNIS(9;BEREICH.VERSCHIEBEN(B1;;;ZEILE(1:99))))}
Variante mit SUMMEWENN und INDIREKT:
{=MAX(SUMMEWENN(INDIREKT("B1:B"&ZEILE(1:99));"<>0";B:B))}

Datum:
{=INDEX(A1:A99;VERGLEICH(D6;TEILERGEBNIS(9;BEREICH.VERSCHIEBEN(B1;;;ZEILE(1:99)));0))}
oder:
{=INDEX(A1:A99;VERGLEICH(D6;SUMMEWENN(INDIREKT("B1:B"&ZEILE(1:99));"<>0";B:B);0))}