Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Namen - BEITRAG: In diskontinuierlichem Bereich mit INDEX auf Teilbereiche zugreifen


Aufgabe
Wie kann man in einem diskontinierlichen Bereich auf die Teilbereiche zugreifen ?


Lösung
Bereich = "BereichX"

bezieht sich auf A1:A3;A7:A9;C1:D3;C7:D9

=SUMME(INDEX(BereichX;1))
bildet nur die Summe von A1, ignoriert C1 und D1

=SUMME(INDEX(BereichX;;;2))
bildet die Summe von A7:A9

=SUMME(INDEX(BereichX;;;2))
bildet die Summe von C1:D3

=INDEX(BereichX;3;2;3)
nimmt den Wert aus D3

=MITTELWERT(INDEX(BereichX;1;;4))
Durchschnitt von C7:D7
Erläuterung
VORSICHT: Wenn man den Namen vergibt, kommt es darauf an, in welcher Reihenfolge man die Teilbereiche
selektiert.
Bei A1:A3;A7:A9;C1:D3;C7:D9

ist A7:A9 der Teilbereich 2 und C1:D3 ist der Teilbereich 3.

Wenn man bei der Namensvergabe erst A1:a3, dann C1:D3 und dann A7:A9 selektiert, lautet der Bezug
A1:A3;C1:D3;A7:A9;C7:D9

dann ist C1:D3 der Teilbereich 2 und A7:A9 der Teilbereich 3