Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Gültigkeit - BEITRAG: In einer Liste doppelte Einträge und Leerzellen verbieten.


Aufgabe
Beim händischen Eingeben von Daten in Listen soll verhindert werden, daß der Nutzer versehentlich eine schon einmal vergebene Nummer nochmals vergibt.
Außerdem soll verhindert werden, daß eine "Lücke" (Leerzelle) zwischen den Daten entsteht.
Lösung
Selektiere Spalte A, A1 ist die aktive Zelle.

Wähle Daten-Gültigkeit-Gültigkeitskriterien
Zulassen:benutzerdefiniert

Doppelte verbieten:
Formel: =ZÄHLENWENN(A:A;A1)=1

Leerzellen verbieten:
Formel: =ANZAHLLEEREZELLEN(A$1:A1)=0

Doppelte bezogen auf zwei Spalten verbieten (gleiche Wertepaare):
Selektiere A1:B100, A1 ist die aktive Zelle.
=SUMME(WENN($A$1:$A$100&$B$1:$B$100=$A1&$B1;1))=1


Das System soll dem Nutzer noch sagen, was er falsch gemacht hat.
Wähle dazu in der Dialogbox "Gültigkeit" den Reiter "Fehlermeldung" und gib einen passenden Titel sowie eine verständliche Fehlermeldung ein.