Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Ist heute bzw. wann ist/war Vollmond ?


Aufgabe
Ausgehend von heute bzw. von einem anderen Datum aus, willst Du wissen, wann die nächste Vollmondnacht ist, bzw. wann die letzte war.


Lösung
Das Datum steht in A1.

der nächste Vollmond (inklusive Datum in A1):
{=A1+MIN(WENN(REST(A1+ZEILE(X1:X33)-106,6213922;29,530588)+1>29,530588;ZEILE(X1:X33)))-1}

der letzte vor A1:
{=A1+1-MIN(WENN(REST(A1+1-ZEILE(X1:X33)-106,6213922;29,530588)+1>29,530588;ZEILE(X1:X33)))-1}

Ergebnisse als Datum formatiert.


Die direkte Abfrage, ob an A1 Vollmond ist:
=WENN((REST(A1-105,6213922;29,530588)+1)>29,530588;"Vollmond";"")

Statt "Vollmond" z.B. "☻" (mit Alt2 auf dem Ziffernblock) für einen Kalender.


Erläuterung
Der ausführliche Mond ist natürlich unser:
Tip Nr. 49