Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Kombination / Anzahlminimierung von 2 Summanden


Aufgabe
Eine vorgegebene Zahl soll durch Kombination von 2 (mehrfachen) Summanden dargestellt werden. Die Gesamtzahl der Summanden ist dabei zu minimieren.
z.B. 12.345 sowie die Summanden 112 und 111 ergeben 24*112 + 87*111


Lösung
in A1 steht die Zielzahl
in A2 steht der größere Summand
in A3 der kleinere

in B2 steht die Arrayformel:
{=MAX((WECHSELN((A1-(A2*ZEILE(X1:X999)))/A3;"-";)*1=GANZZAHL((A1-(A2*ZEILE(X1:X999)))/A3))*ZEILE(X1:X999))}

in B3:
=WENN(REST((A1-B2*A2)/A3;1);"unlösbar";(A1-B2*A2)/A3)


Erläuterung
Siehe auch (mit logischer Abstufung): "einen (Geld-)Betrag optimal stückeln"
Formel Nr.338