Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Kombinationen von Zweiern, Dreiern und Vierern auflisten


Aufgabe
Es sollen alle möglichen Dreier-und-Vierer-Kombinationen ohne Wiederholung aufgelistet werden.

       A               B               C               D               E               F               G               H               I       
1 6    4  
2 20 Dreier    5  
3 15 Vierer    6  
4     5  
5     6  
6     6  
7     5  
8     6  
9     6  
10     6  
11     5  
12     6  
13     6  
14     6  
15     6  
16            
17            
18            
19            
20            

Lösung
In A1 wird die Zahlenmenge eingegeben.

In A2 steht:
=FAKULTÄT(A1)/(FAKULTÄT(3)*FAKULTÄT(A1-3))&" Dreier"
In A3:
=FAKULTÄT(A1)/(FAKULTÄT(4)*FAKULTÄT(A1-4))&" Vierer"

Dreier
In B1, C1 und D1 stehen die Zahlen 1, 2 und 3
in B2 steht:
=WENN(ODER(B1=$A$1-2;B1="");"";WENN(C1=$A$1-1;B1+1;B1))
in C2:
=WENN(B2="";"";WENN(B2<>B1;B2+1;WENN(D1=$A$1;C1+1;C1)))
in D2:
=WENN(B2="";"";WENN(D1=$A$1;C2+1;D1+1))
und runterkopieren

Vierer:
in F1 bis i1 stehen die Zahlen 1 bis 4
in F2:
=WENN(ODER(F1=$A$1-3;F1="");"";WENN(G1=$A$1-2;F1+1;F1))
in G2:
=WENN(F2="";"";WENN(F2<>F1;F2+1;WENN(H1=$A$1-1;G1+1;G1)))
in H2:
=WENN(F2="";"";MIN($A$1-1;WENN(G2<>G1;G2+1;WENN(I1=$A$1;H1+1;H1))))
in i2:
=WENN(F2="";"";WENN(I1=$A$1;H2+1;I1+1))
und runterkopieren

Ergänzung vom 15.03.2006
Die Zweier hatten wir bisher nicht:
In A1 steht die Zahlenmenge
B1:1
C1:2
B2:=WENN(B1+1=$A$1;"";WENN(ZÄHLENWENN(B$1:B1;B1)>=$A$1-B1;B1+1;B1))
C2:=WENN(B2>B1;B2+1;C1+1)
(B2:C2 runterkopieren)