Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Kreuztabelle auflösen, d.h. in Datensatzform darstellen


Aufgabe
Du hast eine Kreuztabelle bzw. Pivottabelle und willst jedes Feld des Datenbereiches mit zugehöriger Spalten- und Zeilenbeschriftung dargestellt bekommen.

       A               B               C               D               E               F               G               H               I               J       
1   Andy  WF  Jens  Klaus    868  Andy  Mo  
2 Mo  868  534  334  958    534  WF  Mo  
3 Di  584  255  942  423      334  Jens  Mo  
4 Mi  582  387  792  218      958  Klaus  Mo  
5 Do  271  542  736  505      584  Andy  Di  
6 Fr  418  728  573  369      255  WF  Di  
7 Sa  783  694  682  620      942  Jens  Di  
8 So  608  368  506  171      423  Klaus  Di  
9               582  Andy  Mi  
10               387  WF  Mi  
11               792  Jens  Mi  
12               218  Klaus  Mi  
13               271  Andy  Do  
14               542  WF  Do  
15               736  Jens  Do  
16               505  Klaus  Do  
17               418  Andy  Fr  
18               728  WF  Fr  
19               573  Jens  Fr  
20               369  Klaus  Fr 

Lösung
Kreuztabelle von A1:E8

Der Datenbereich geht also von B2:E8

in G1 kommt die Anzahl der Spalten im Datenbereich (also 4)
in G2 kommt die Anzahl der Zeilen im Datenbereich (also 7)

ab H1 stehen die Werte:
=WENN(ZEILE(A1)>G$1*G$2;"";INDEX(B$2:F$20;KÜRZEN((ZEILE(A1)-1)/$G$1)+1;REST(ZEILE(A1)-1;$G$1)+1))

ab I1 stehen die Spaltenbeschriftungen
=WENN(ZEILE(A1)>$G$1*$G$2;"";INDEX($B$1:$E$1;REST(ZEILE(A1)-1;$G$1)+1))

ab J1 stehen die Zeilenbeschriftungen
=WENN(ZEILE(A1)>$G$1*$G$2;"";INDEX(A:A;KÜRZEN((ZEILE(A1)-1)/$G$1)+1+1))

(H1; I1 und J1 runterkopieren)