Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Leerzellen sowie Nullwerte nicht auflisten


Aufgabe
Ohne eine der Filterfunktionen von Excel zu benutzen soll eine Spalte automatisch ohne die darin enthaltenen Leerzellen und Nullen aufgelistet werden.

       A               B               C       
1   1  
2   a  
3   b  
4     x  
5   h  
6   3  
7     4  
8      
9    
10      
11    
12    

Lösung
Es geht um die Spalte A1 bis A99

{=WENN(ZEILE()>SUMME(1*(A$1:A$99<>0));"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$99<>0;ZEILE($1:$99));ZEILE())))}
und runterkopieren

kürzer:
{=INDEX(A:A;KKLEINSTE(WENN(A$1:A$99<>0;ZEILE($1:$99);101);ZEILE()))}
und in Zelle A101 ="" schreiben (ergibt sonst 0 bei keinen weiteren Treffern)

ab Excel2007:
{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(A$1:A$99<>0;ZEILE($1:$99));ZEILE()));"")}