Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: Links von Text stehende Zahlen addieren


Aufgabe
Wenn Du zahlen addieren willst, die links vom Text stehen,
muß entweder die Textlänge oder die Länge der Zahl konstant sein bzw. Zahl und Text durch ein eindeutiges Zeichen getrennt sein.
Im Beispiel ist die Textlänge konstant.

       A               B               C       
1 123 x  Summe  1.181,90  
2 45 y     
3 12,90 z     
4 1.000,00 x     
5 1 y     

Lösung
Bereich: A1:A5
Textlänge rechts: 2

{=SUMME(LINKS(A1:A5;LÄNGE(A1:A5)-2)*1)}

Ist die Länge der Zahlen konstant und der Text rechts variabler Länge, dann
{=SUMME(LINKS(A1:A5;3)*1)}
(addiert die 3 linken Ziffern)

Sind Zahlen- und Textlänge beide variabel müssen sie durch ein eindeutiges Zeichen (z.B.: ein Leerzeichen) voneinander getrennt sein.
{=SUMME(LINKS(A1:A5;FINDEN(" ";A1:A5))*1)}