Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: Liste der Formeln, die Add-In-Funktionen ersetzen + weitere


Aufgabe
Welche Add-Ins können durch Formeln ersetzt werden?

Gibt man eine Datei weiter und auf dem anderen Rechner ist das Add-In "Analysefunktionen" nicht geladen, erhält der Anwender Fehlermeldungen. Dieses Zeug muß dringendst vermieden werden.

Selbst, wenn das ADD-In aktiviert ist, gibt es sehr oft Müll, denn die jeweiligen Funktionen sind auf manchen Rechnern in deutsch und auf anderen Rechnern in englisch, obwohl die Funktionsbeschreibung deutsch ist!

Lösung

       A               B               C       
1 Add-In  Ersatz  Kategorie  
2 ARBEITSTAG  13  Datum/Zeit  
3 BININDEZ   113  Zahlensysteme  
4 DEZINBIN   114  Zahlensysteme  
5 DEZINOKT   116  Zahlensysteme  
6 EDATUM  Datum/Zeit  
7 EFFEKTIV  148  Finanzmathematik  
8 GAUSSFEHLER  294  Statistik  
9 GGT   130  mathematische Funktionen  
10 HEXINDEZ   117  Zahlensysteme  
11 KALENDERWOCHE   Datum/Zeit  
12 KGV   131  mathematische Funktionen  
13 KUMKAPITAL   267  Finanzmathematik  
14 KUMZINSZ  267  Finanzmathematik  
15 NETTOARBEITSTAGE   11  Datum/Zeit  
16 NOMINAL  148  Finanzmathematik  
17 OKTINDEZ   115  Zahlensysteme  
18 XINTZINSFUSS   203  Finanzmathematik  
19 XKAPITALWERT  21  Finanzmathematik  
20 ZW2  297  Finanzmathematik  
21 ZWEIFAKULTÄT  288  mathematische Funktionen 

Zusätzlich können noch nachfolgende Add-Ins durch Formeln ersetzt werden:

       A               B       
1 Add-In  Formel-Ersatz  
2 =BRTEILJAHRE(A1;B1;2)  =(B1-A1)/360  
3 =DELTA(A1;B1)  =(A1=B1)*1  
4 =GGANZZAHL(A1;B1)  =(A1>=B1)*1  
5 =ISTGERADE(A1)  =REST(KÜRZEN(A1);2)=0  
6 =ISTUNGERADE(A1)  =REST(KÜRZEN(A1);2)=1  
7 =MONATSENDE(A1;B1)  =DATUM(JAHR(A1);MONAT(A1)+1+B1;0)  
8 =QUOTIENT(A1;B1)  =KÜRZEN(A1/B1)  
9 =VRUNDEN(A1;B1)  =RUNDEN(A1/B1;0)*B1  
10 =WURZELPI(A1)  =(A1*PI())^0,5  
11 =ZUFALLSBEREICH(A1;B1)  =RUNDEN(ZUFALLSZAHL()*(B1-A1+1)+A1-0,5;0) 


Erläuterung
Ab Excel-2007 sind diese integriert - obiges ist dann überflüssig.