Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Mathematische Funktionen - BEITRAG: Lösung einer quadratischen Gleichung


Aufgabe
Eine quadratische Gleichung der Form ax^2 + bx + c = d soll gelöst werden.

       A               B               C       
1   3x^2 + 7x + 5 = 31  
2    
3    
4 31     
5      
6 x1   
7 x2  -4,333   

DOWNLOAD
mit Diagramm


Lösung
in Zelle A1 steht der Wert für a; in A2 der für b; in A3 der für c und in A4 der für d.

Nachfolgende "Bombenlegerformel" in C1 ist für die Lösung unnötig und dient nur der Darstellung:
=WECHSELN(WENN(A1;TEXT(A1;"[=-1]""-"";[=1]"""";Standard")&"x² ";"")&WENN(UND(A2>0;A1<>0);"+ ";"")&WENN(A2;TEXT(A2;"[=-1]""-"";[=1]"""";Standard")&"x ";"")&WENN(A3;TEXT(A3;"+ ;""""")&A3;"")&WENN(A4;" = "&A4;" = 0");"-";"- ")
In englischer Excelversion muss in der Formel das Wort Standard durch General ersetzt werden. (Korrektur 26.10.2016)

3x² + 7x + 5 = 31


Das Ergebnis für X1:
=WENN(A1=0;-(A3-A4)/A2;WENN(ISTFEHLER((-A2+(A2*A2-4*A1*(A3-A4))^0,5)/(A1*2));"komplexe Wurzel";(-A2+(A2*A2-4*A1*(A3-A4))^0,5)/(A1*2)))

Das Ergebnis für X2:
=WENN(ODER(A1=0;4*A1*(A3-A4)-A2*A2=0);"es gibt nur eine Lösung";WENN(ISTFEHLER((-A2-(A2*A2-4*A1*(A3-A4))^0,5)/(A1*2));"komplexe Wurzel";(-A2-(A2*A2-4*A1*(A3-A4))^0,5)/(A1*2)))

Erläuterung
Die - rein mathematische - Lösung einer kubischen Gleichung (Gleichung dritten Grades) ist Tip Nr. 37 mit download in der Kategorie Mathematik.