Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Verweisfunktionen - BEITRAG: Maximalwert eines Wochentags bestimmen*


Aufgabe
In Spalte A stehen Datumswerte; in Spalte B die entsprechenden Umsatzzahlen.
In Zelle C1 wird ein Wochentag eingegeben und es soll der höchste Umsatz für diesen Wochentag ermittelt werden.
       A               B               C       
1 Mi, 26.9.01  100 DM  Freitag  
2 Do, 27.9.01  500 DM   
3 Fr, 28.9.01  400 DM   
4 Sa, 29.9.01  800 DM   
5 So, 30.9.01  1.000 DM   
6 Mo, 1.10.01  600 DM   
7 Di, 2.10.01  900 DM   
8 Mi, 3.10.01  300 DM   
9 Do, 4.10.01  200 DM   
10 Fr, 5.10.01  600 DM   
11 Sa, 6.10.01  900 DM   
12 So, 7.10.01  200 DM   
13 Mo, 8.10.01  650 DM   
14 Di, 9.10.01  700 DM   
15 Mi, 10.10.01  750 DM   
16 Max von Freitag  600 DM   
Lösung
das Ergebnis (Array-Formel):
{=MAX(((WOCHENTAG(A1:A16;2)=VERGLEICH(C1;{"Montag";"Dienstag";"Mittwoch";"Donnerstag";"Freitag";"Samstag";"Sonntag"};0))*(B1:B16)))}

Verkürzung von Holger Voß:
{=MAX((TEXT(A1:A16;"TTTT")=C1)*B1:B16)}