Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Maximum und Summe des jeweils letzten Datensatzes *


Aufgabe
Du hast eine Liste variabler Länge. Periodisch werden Datensätze angehängt.
Du willst nun immer eine Auswertung (Summe, Maximum) des letzten (aktuellen) Datensatzes haben.

       A               B               C               D               E               F               G       
1 Datum  Klaus  Andy  WF  Jens  Max  Summe  
2 01.01.00  661  887  327  333  748  1990  
3 01.02.00  935  594  899  621     
4 01.03.00  898  500  622  445     
5 01.04.00  548  144  961  560     
6 01.05.00  990  158  421  316     
7 01.06.00  295  955  411  273     
8 01.07.00  519  166  965  577     
9 01.08.00  423  355  952  696     
10 01.09.00  195  748  705  342     

Lösung
Datenbankbereich: Spalte A:E
Datum: Spalte A
Werte: Spalte B:E

Summe:
{=SUMME(BEREICH.VERSCHIEBEN(B1:E1;MAX(WENN(B1:E1000<>"";ZEILE(1:1000)))-1;))}

Max:
{=MAX(BEREICH.VERSCHIEBEN(B1:E1;MAX(WENN(B1:E1000<>"";ZEILE(1:1000)))-1;))}

Verkürzung von Christian Hapke:
{=MAX((A3:A1000="")*B2:E999)}
und
=SUMMENPRODUKT((A3:A1000="")*B2:E999)