Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Verweisfunktionen - BEITRAG: Mehrspaltiges und mehrfach vorkommendes Suchkriterium


Aufgabe
Es sollen zwei Spalten nach zwei Suchkriterien "x" und "y" durchsucht werden, die gleichzeitig erfüllt sein müssen.
Zudem kann die Kombination aus Suchkriterium "x" und "y" mehrfach vorkommen.
{=INDEX(C1:C1000;VERGLEICH("x"&"y";A1:A1000&B1:B1000;0))} liefert nur den ersten Treffer, im Beispiel die 9.

       A               B               C       
1 17  
2 5  
3 9  
4 20  
5 8  
6 4  
7 1  
8 19  
9 22  
10      
11 Zweiter  Treffer  8  
12 Dritter  Treffer  19 

Lösung
Suchspalte 1 : A, Suchbegriff "x"
Suchspalte 2 : B, Suchbegriff "y"
Ergebnisspalte: C

{=INDEX(C1:C1000;KKLEINSTE(WENN((A1:A1000="x")*(B1:B1000="y");ZEILE(1:1000));2))}
liefert den zweiten Treffer.

{=INDEX(C1:C1000;KKLEINSTE(WENN((A1:A1000="x")*(B1:B1000="y");ZEILE(1:1000));3))}
liefert den dritten Treffer.

Ergänzung vom 02.12.2003
zum Kopieren ab dem ersten Wert und ohne Fehlermeldung wenn keine weiteren Kombinationen mehr vorkommen:

{=WENN(ZEILE(A1)>SUMME((A$1:A$1000&B$1:B$1000="x"&"y")*1);"";INDEX(C$1:C$1000;KKLEINSTE(WENN((A$1:A$1000="x")*(B$1:B$1000="y");ZEILE($1:$1000));ZEILE(A1))))}
und runterkopieren


Erläuterung
Die Gross-Klein-Schreibung der Suchkriterien wird ignoriert.