Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: Monatsanzahl für ein bestimmtes Jahr in einem Zeitraum *


Aufgabe
Für ein bestimmtes Jahr in A1 soll die Monatsanzahl für den Zeitraum von A2 bis B2 ermittelt werden.

       A               B               C               D               E               F       
1 2012      tangierte  komplette  Monate  
2 17.02.2012  03.12.2012    11  9   
3 12.09.2011  17.04.2012    4  3   
4 15.03.2013  20.07.2014    0  0   
5 15.09.2011  24.02.2013    12  12   
6 25.12.2011  01.01.2012    1  0   

Lösung
alle tangierten Monate:
=(MONAT(MIN(DATUM(A$1;12;31);B2))-MONAT(MAX(DATUM(A$1;1;1);A2))+1)*(JAHR(A2)<=A$1)*(JAHR(B2)>=A$1)

nur die kompletten Monate (auch Monatserster von und Monatsletzter bis fliegt raus):
=WENN(ODER(A$1 > JAHR(B2);A$1 < JAHR(A2));0;MAX(0;WENN(JAHR(B2)=A$1;MONAT(B2)-1;12)-WENN(JAHR(A2)=A$1;MONAT(A2);0)))

Anzahl eines bestimmten Monats zwischen 2 Daten in A1 und B1
hier: März (3) tangiert:
=(MONAT(A1)<=3)-(MONAT(B1)<3)+JAHR(B1)-JAHR(A1)

nur kompletter Monat (von lupo1):
=MAX(0;JAHR(B1)-JAHR(A1)-1+(MONAT(A1)<3)+(MONAT(B1)>3))