Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Nachfolgende Spalten von gefundenem Suchkriterium summieren *


Aufgabe
Mit der SVERWEIS-Funktion soll ein Suchbegriff gefunden werden.
Nun soll nicht ein Einzelwert wiedergegeben werden, sondern die Summe aller benachbarten Werte bzw. deren Maximum

       A               B               C               D               E               F               G               H               I               J       
1 905  274  578  377  403  219  964  262  459  
2 149  966  721  406  801  224  901  426  620  
3 198  712  647  217  739  543  776  867  525  
4 733  791  829  765  478  566  990  597  399  
5 x  746  174  801  477  615  222  727  141  248  
6 181  644  882  259  189  450  793  276  130  
7 429  718  573  762  572  616  268  910  362  
8 149  506  164  204  714  100  732  948  780  
9 604  172  211  764  121  137  485  585  783  
10                    
11 Summe  4.151                 
12 Max  801                 

Lösung
Matrix: A1:J100
Suchbegriff: "x"

Summe:
{=SUMME(SVERWEIS("x";A1:J100;SPALTE(B:J);0))}
oder
{=SUMME(SVERWEIS("x";A1:J100;{2;3;4;5;6;7;8;9;10};0))}

ohne Array-Formel (beide von P. Wanninger)
=SUMME(BEREICH.VERSCHIEBEN(B1:J1;VERGLEICH("x";A1:A100;0)-1;0))
oder
=SUMME(INDEX(B1:J100;VERGLEICH("x";A1:A100;0);0))

Maximum:
identische obige Formeln mit MAX statt SUMME

Erläuterung
Findet statt SVERWEIS (Zeilen) der WVERWEIS (Spalten) Anwendung, dann in der ersten Formel als Platzhalter nicht SPALTE(B:J) sondern ZEILE(2:10) verwenden (Anpassung beim Einfügen von Zeilen).