Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: Nur Zahlen ohne ihre Doppler summieren


Aufgabe
In Spalte A stehen Zahlen, die auch mehrfach vorkommen können.
Jetzt sollen alle Zahlen ohne ihre Wiederholungen summiert werden.

Lösung
{=SUMME(WENN(A1:A100<>"";1/ZÄHLENWENN(A1:A100;A1:A100)*A1:A100))}

Wenn im Suchbereich auch Texte vorkommen können, dann gibt´s bei obiger Formel Mecker (#WERT!). Abhilfe:

{=SUMME(WENN(ISTZAHL(A1:A100);1/ZÄHLENWENN(A1:A100;A1:A100)*A1:A100))}

oder (etwas länger, dafür mit anderen Logiken):
{=SUMME(WENN(ISTZAHL(A1:A100);(VERGLEICH(A1:A100;A1:A100;)=ZEILE(1:100))*A1:A100))}
{=SUMME(WENN(ZÄHLENWENN(INDIREKT("A1:A"&ZEILE(1:100));A1:A100)=1;A1:A100))}

Tauchen die Doppler nur hintereinander auf, wirds einfacher:
{=SUMME(WENN(A1:A99<>A2:A100;A1:A99))}




Erläuterung
Ist nichts anderes als eine simple Ergänzung von Tip 42 (bei Zählfunktionen). In dieser Rubrik würde man aber nicht suchen, wenn man summieren will.