Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Nur aktuelle Datensätze summieren


Aufgabe
Du hast eine expandierende Liste in der sich Einträge in Spalte A
wiederholen. Es soll nun von jedem Eintrag jeweils nur der letzte, also
aktuelle Datensatz summiert werden.

       A               B       
1 Name  Betrag  
2 Walter  604  
3 Jens  745  
4 Andy  118  
5 Klaus  819  
6 Jens  649  
7 Andy  847  
8 Andy  213  
9 Walter  308  
10 Jürgen  783  
11 Sven  336  
12    
13 Summe  3.108 

Lösung
Kriterienspalte: A
Betragsspalte: B

{=SUMME(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A1;;;ZEILE(INDIREKT("1:100")););A1:A100)=ZÄHLENWENN(A1:A100;A1:A100);B1:B100))}