Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Oberbegriff eines Suchstrings ausgeben


Aufgabe
In Spalte A stehen Oberbegriffe und darunter Unterbegriffe; - im Beispiel Bundesländer und Städte.
Nach Eingabe eines Unterbegriffs (auch Teilstring) in C1 soll in C2 der dazugehörige Oberbegriff ausgegeben werden.
Wurde in C1 nur ein Teilstring eingegeben, soll in C4 der komplette Unterbegriff ausgegeben werden.


       A               B               C       
1     karls  
2 Nordrhein-Westfalen    Baden-Württemberg  
3 Düsseldorf und Köln     
4 Essen    Karlsruhe  
5 Neuss, Krefeld     
6 Münster     
7 Dortmund, Gelsenkirchen     
8      
9 Baden-Württemberg     
10 Karlsruhe     
11 Stuttgart     
12 Freiburg, Konstanz, Ulm     
13      
14 Hessen     
15 Bad Vilbel, Frankfurt, Wiesbaden     
16 Kassel     

Lösung
in C2:
=VERWEIS(2;1/(A1:INDEX(A:A;VERGLEICH("*"&C1&"*";A:A;))="");A2:A999)

in C4:
=WENN(ISTNV(VERGLEICH(C1;A:A;));SVERWEIS("*"&C1&"*";A:A;1;);"")
bzw.
=WENNFEHLER(SVERWEIS("*"&C1&"*";A:A;1;);"")

Erläuterung
Die Formel funktioniert nur, wenn oberhalb des jeweiligen Oberbegriffs mindestens eine Leerzelle vorkommt.

Kommt ein Suchbegriff (ob als Teilstring oder auch in Gänze) mehrmals vor, wird der 1. Treffer ermittelt.