Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zählfunktionen - BEITRAG: Personen mit einem bestimmten Alter zählen


Aufgabe
Es sollen aus einer Datumsspalte mit Geburtstagen alle Personen gezählt werden, die zwischen 20 und 30 Jahren alt sind.
Lösung
Spalte = A

{=SUMME((DATEDIF(A1:A100;HEUTE();"Y")<=30)*(DATEDIF(A1:A100;HEUTE();"Y")>20))}
verkürzt:
{=SUMME((DATEDIF(A1:A100;HEUTE();"Y")<={30.20})*{1.-1})}

oder

{=INDEX(HÄUFIGKEIT(DATEDIF(A1:A100;HEUTE();"Y");{20;30});2)}

Erläuterung
In der Häufigkeitsformel wird die Obergrenze immer mitgerechnet, also größer als die Untergrenze und kleiner gleich die Obergrenze.