Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Mathematische Funktionen - BEITRAG: Prüfsumme nach dem Luhn-Algorithmus


Aufgabe
Der Luhn-Algorithmus oder die Luhn-Formel, auch bekannt als „Modulo 10“- oder „mod 10“-Algorithmus, wurde in den 1960er Jahren von Hans Peter Luhn entwickelt. Er ist eine simple Prüfsummen-Formel, die benutzt wird, um eine Vielzahl von Identifikationsnummern wie Kreditkartennummern und kanadische Sozialversicherungsnummern zu bestätigen.

Der Algorithmus läuft in drei Schritten ab. Im ersten Schritt wird jede zweite Ziffer, beginnend von rechts, verdoppelt. Wenn das Resultat größer als 9 ist, wird die Quersumme des Resultats der Verdopplung gebildet. Im zweiten Schritt werden alle Zahlen summiert. Schließlich im letzten Schritt wird das Resultat durch 10 dividiert.
Ist der Rest gleich 0 (die letzte Ziffer ist 0), hat die originale Ziffernfolge die Prüfung bestanden.

Beispiele:
8763 => 16+7+12+3 => 7+7+3+3 (=1+6+7+1+2+3) => 20 => REST(20;10)=0 - also OK
7941 => 14+9+8+1 => 5+9+8+1 (=1+4+9+8+1) => 23 => REST(23;10)=3 - also durchgefallen

Lösung
In A1 steht die zu prüfende Zahl.

Die luhnsche Quersumme lautet:
{=SUMME(1*TEIL(TEXT(LINKS(RECHTS(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)))))*WENN(REST(ZEILE(INDIREKT("1:"&LÄNGE(A1)));2)=0;2;1);"00");SPALTE(A:B);1))}