Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Prüft, ob eine Spalte sortiert ist *


Aufgabe
Du willst wissen, ob eine bestimmte Spalte sortiert ist.
Lösung
Spalte: A (Überschrift in A1 Sortierung ja/nein ab A2)

Folgende Formel liefert WAHR, wenn Spalte A aufsteigend sortiert ist.
{=SUMME(N((A3:A1002)<(A2:A1001)))=WENN(A1002="";1;0)}
verkürzt von Christian Hapke:
{=SUMME(N(A3:A1002 < A2:A1001))=N(A1002="")}


WAHR bei absteigender Sortierung ist etwas einfacher:
{=SUMME(N(A3:A1002 > A2:A1001))=0}
oder (Dominik Petri):
{=UND(A3:A1002<=A2:A1001)}