Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Prüfung, ob zwei Spalten identisch sind


Aufgabe
Du willst wissen, ob 2 Spalten identisch sind; - also betreffend Inhalt und Sortierung.
Lösung
Die zu vergleichenden Spalten sind A und B
{=WENN(UND(A1:A1000=B1:B1000);"";"nicht ")&"identisch"}

Die Anzahl der Abweichungen ergibt:
{=SUMME(N(A1:A1000<>B1:B1000))}


Soll auf absolute Identität - also auch auf Groß- und Kleinschreibung - geprüft werden, dann:
{=WENN(UND(IDENTISCH(A1:A1000;B1:B1000));"";"nicht ")&"identisch"}

{=SUMME(N(NICHT(IDENTISCH(A1:A1000;B1:B1000))))}