Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Punkte von 240 bis 0 den Noten 1 bis 6 zuordnen


Aufgabe
Bei einer maximal zu erreichenden Punktzahl von 240 sollen für die erreichte Punktzahl Noten vergeben werden.
Folgende Aufteilung gilt:

       A               B               C               D       
1 Punkte:    Punkte   Note  
2 205    240 bis 221   1  
3     220 bis 196   2  
4 Note:    195 bis 161   3  
5   160 bis 121   4  
6     120 bis 71   5  
7     70 bis 0  

Lösung
Punktzahl steht in A2

=VERGLEICH(A2;{240.220.195.160.120.70};-1)

Ergänzung vom 15.10.2004
=VERWEIS(A2;{0.71.121.161.196.221};{6;5;4;3;2;1})
macht dasselbe.
Statt Zahlen gleichen Abstands kann man aber auch individuelle Noten oder
=VERWEIS(A2;{0.71.121.161.196.221};{"F";"E";"D";"C";"B";"A"})
Texte
=VERWEIS(A2;{0.71.121.161.196.221};{"ungenügend";"mangelhaft"; "ausreichend";"befriedigend";"gut";"sehr gut"})
einsetzen.