Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Mathematische Funktionen - BEITRAG: Quersumme einer Zahl ermitteln


Aufgabe
Aus einer gegebenen natürlichen Zahl soll die Quersumme ermittelt werden.
Definition: Die Quersumme einer Zahl ist die Summe ihrer Ziffern.
Die Anzahl der Ziffern soll dabei variabel sein.
Beispiel:
       A               B       
1 Gegebene Zahl  Quersumme  
2 12345  15  
3 273464  26 

Lösung
Zahl steht in A1

{=SUMME(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*1)}
bzw.
=SUMMENPRODUKT(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*1)
oder
=SUMMENPRODUKT((0&TEIL(A1;SPALTE($A$1:$IQ$1);1))*1)

Die Quersumme eines Datums ist:
=SUMMENPRODUKT(TEIL(TEXT(A1;"TTMMJJJJ");ZEILE(1:8);1)*1)

Das Querprodukt (Multiplikation aller Ziffern) ermittelt man mit:
{=PRODUKT(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*1)}

Ergänzung 29.08.05

Berechnung der iterierten Quersumme.

Es soll so oft die Quersumme der Quersumme berechnet werden, bis nur noch eine einstellige Zahl übrig bleibt.
Statt die herkömmliche Formel nach unten zu kopieren, soll diese Berechnung in einer Zelle erfolgen.

Für Ausgangszahlen bis zu einer Länge von 15 Ziffern von Franz Pölt:
=(REST(A1-KÜRZEN(A1/9)*9;-9)+9)*(A1>0)

Für Zahlstrings beliebiger Länge von Josef Burch:
{=(A1>0)*(REST(SUMME((0&TEIL(A1;SPALTE($A$1:$IQ$1);1))*1)-1;9)+1)}