Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Mathematische Funktionen - BEITRAG: Quersumme nach dem Double-Add-Double Prinzip


Aufgabe
Jede zweite Ziffer soll mit 2 multipliziert - beginnend von rechts mit der vorletzten - und anschließend die Quersumme gebildet werden
Dieser Vorgang soll mit der so gefundenen Zahl so oft wiederholt werden, bis ein einstelliges Ergebnis vorliegt.

       A       
1 54.178  
2 36  
3 12  
4 4  
5  
6  
7  
8 8 + 7*2 +1 + 4*2 + 5 = 36  
9 6 + 3*2 = 12  
10 2 + 1*2 = 4 

Lösung
Die Zahl steht in A1

in A2 steht:
{=WENN(ODER(LÄNGE(A1)=1;A1="");"";WENN(REST(LÄNGE(A1);2)=0;SUMME(("0"&TEIL(A1;SPALTE($1:$1);1))*2)-SUMME(("0"&TEIL(A1;SPALTE($1:$1)*2;1))*1);SUMME(("0"&TEIL(A1;SPALTE($1:$1);1))*1)+SUMME(("0"&TEIL(A1;SPALTE($1:$1)*2;1))*1)))}
und runterkopieren

Verkürzung vom 30.01.2005:
=WENN(MIN(A$1:A1)<10;"";SUMMENPRODUKT((0&TEIL(A1;SPALTE(1:1);1))*(1+REST(SPALTE(1:1)-REST(LÄNGE(A1);2);2))))

Variante "Quersumme spezial":
Aus einer beliebigen Ganzzahl soll die Quersumme ermittelt werden - allerdings wird zunächst jede 2. Ziffer (beginnend bei der 1. von links) mit 2 multipliziert. Aus diesem Ergebnis wird wiederum die Quersumme ermittelt und in das Gesamtergebnis übernommen (die mit 2 multiplizierte Zahl selbst dann nicht mehr).

Beispiel: 54178
=5*2 (Quersumme = 1) + 4 + 1*2 (Quersumme = 2) + 7 + 8*2 (Quersumme = 7)
Ergebnis: 21

=SUMMENPRODUKT(TEIL((0&TEIL(A1;SPALTE(1:1);1))*(1+REST(SPALTE(1:1);2))&0;{1;2};1)*1)

Erläuterung
Dieses Verfahren (nur Schritt 1) findet z.B. Anwendung bei Wertpapierkennnummern.