Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: Rang von Zahlen und Text ermitteln


Aufgabe
Wie kann man den Rang einer Zahl innerhalb einer Liste ermitteln ?
Wie funktioniert das mit Text?

       A               B       
1 Klaus  8  
2 Frank  3  
3 Walter  10  
4 Andy  2  
5 Jens  5  
6 Verena  9  
7 Alexandra  1  
8 Jürgen  7  
9 Heidrun  4  
10 Jörg  6  
11    
12 3.Rang:  Frank 

Lösung
Liste: A1:A10

Rang von Zahlen (losgelöst von obigem Beispiel stehen 10 Zahlen in A1:A10):

in B1 steht:
=RANG(A1;A$1:A$10;1)
Diese Formel runterkopieren

Rang von Text (bezogen auf obiges Beispiel):
!!!Der Bereich darf keine Leerzellen enthalten.!!!
In B1: =SUMMENPRODUKT((A1>A$1:A$10)*1)+1
Diese Formel runterkopieren
Können doch Leerzellen vorkommen, kann man das mit
=SUMMENPRODUKT((A1>A$1:A$10)*1)+1-ANZAHLLEEREZELLEN(A$1:A$10)
abfangen.

So kann ein bestimmtes Element ausgegeben werden,
z.B. das 3. Element:
{=INDEX(A1:A10;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A1:A10;"<"&A1:A10)+1;3);ZÄHLENWENN(A1:A10;"<"&A1:A10)+1;0))}
Hier darf der Bereich keine Leerzellen enthalten.