Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: Rangfolge in Abhängigkeit / absoluter Rang


Aufgabe
Teil 1:
In Spalte A stehen Namen und in B Punktzahlen.
In Spalte C sollen die Ränge pro Name aufsteigend aufgeführt werden.

Teil 2:
In Spalte E stehen positive und negative Beträge.
In Spalte F sollen die Rangstellen der Absolutwerte aufsteigend aufgeführt werden.

       A               B               C               D               E               F       
1 Name  Punktzahlen  Rang      Rang-abs  
2 WF  17    12  10  
3 Jens  14    2  
4 Boris  11    -2  6  
5 WF    -1  1  
6 Jens    -7  8  
7 WF  14    7,5  9  
8 Boris    1,5  3  
9 WF  47    6  
10 WF    7  
11 WF    -24  11  
12 Jens    -2 

aufgedröselt/sortiert wären also die aufsteigenden Ränge (Spalte A bis C) bei:
WF 5 - 6 - 9 - 14 - 17 - 47
Jens 3 - 7 - 14
Boris 4 - 11

Lösung
schreibe in C2:
=WENN(A2="";"";SUMMENPRODUKT((A$2:A$99=A2)*(B2>=B$2:B$99)))
und in F2:
=WENN(E2="";"";SUMMENPRODUKT((E$2:E$99<>"")*(ABS(E2)>=ABS(E$2:E$99))))
beide runterkopieren

Sollen die Ränge absteigend aufgeführt werden dann die identischen Formeln mit <=.