Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: Rechts von Text stehende Zahlen variabler Länge addieren


Aufgabe
Man kann über mehrere Zellen den Zahlenteil eines Textes addieren, bei dem sowohl Zahlen als auch Text variabler Länge enthalten sind.
Das funktioniert aber nur wenn die
Zahl rechts steht. Außerdem darf sie kein Komma enthalten.

       A       
1 abc123  
2 defg33  
3 bla1000  
4 Text9  
5 a1  
6 2  
7  
8 1.168 

Lösung
Bereich A1:A10

{=SUMME(A1:A10)+SUMME(WENN(ISTZAHL(A1:A10);0;WENN(ISTZAHL(LINKS(RECHTS(A1:A10;SPALTE(1:1));1)*1);LINKS(RECHTS(A1:A10;SPALTE(1:1));1)*10^(SPALTE(1:1)-1);0)))}

(=SUMME(A1:A10) vorangestellt addiert die Zellen, die Zahlen ohne Text enthalten).