Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: SUMMEWENN in divergierenden Zeilen *


Aufgabe
In Spalte A stehen Datümer, in Spalte B Namen und in Spalte C Kürzel (hier: Schichten: (F)rüh, (S)pät, (N)acht) )
In den Spalten E und F sind diesen Schichtkürzeln Stunden zugeordnet.
Es sollen jetzt die Gesamtstunden ermittelt werden, die Walter (Zelle I1) geplockert hat:

       A               B               C               D               E               F               G               H               I       
1 Datum  Wer ?  Schicht    Schicht  Stunden      Walter  
2 01.01.2010  Boris    8,0    Gesamtstunden  29,5  
3 02.01.2010  Walter    7,0       
4 03.01.2010  Jens    6,5       
5 04.01.2010  Jens             
6 05.01.2010  Walter             
7 06.01.2010  Walter             
8 07.01.2010  Boris             
9 08.01.2010  Walter             
10 09.01.2010  Jens             
11 10.01.2010  Boris             

Lösung
Lösung von AndrRo (Andreas Rost):

Formel in I2:

=SUMMENPRODUKT((B2:B11=I1)*SUMMEWENN(E2:E4;C2:C11;F2:F4))

Erläuterung
Der Clou liegt in der Vertauschung der beiden ersten SUMMEWENN-Parameter Bereich und Suchkriterien.

Wollten wir schon vor der Winzigkeit von 3 Jahren bringen; mir hatte WF´s Beispiel aber nicht gefallen - und das hat eben ein wenig gedauert ;-)