Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: SUMMEWENN in einer gefilterten Liste


Aufgabe
Eine Liste ist nach einem Kriterium in Spalte B gefiltert. Nun sollen alle Zellen summiert werden, die in Spalte C ein bestimmtes Suchkriterium enthalten. Dabei sollen nur die sichtbaren Zellen berücksichtigt werden.
SUMMEWENN kann in einer gefilterten Liste nicht zwischen sichtbaren und unsichtbaren Zellen unterscheiden.



Lösung
Liste geht von A1:C999

Liste ist nach Suchkriterium in Spalte B gefiltert (z.B. 6 größte Elemente)

Summiert werden sollen die sichtbaren Werte in Spalte B, die in Spalte C in gleicher Zeile ein "x" enthalten.

=SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT("B"&ZEILE(S2:S999)))*(C2:C999="x"))

Erläuterung
Häufig begangener Fehler: ist das Suchkriterium in Spalte C eine Zahl, diese nicht mit Gänsen eingeben - also nicht ...="17" sondern ...=17