Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: SUMMEWENN nicht zusammenhängender Spalten + SUMMEWENNS


Aufgabe
Es sollen die Werte in den Spalten D, G, K und M summiert werden, wenn in Spalte A XYZ steht.

Lösung
Natürlich könnte man vier mal SUMMEWENN addieren:
=SUMMEWENN(A:A;"XYZ";D:D)+SUMMEWENN(A:A;"XYZ";G:G)+SUMMEWENN(A:A;"XYZ";K:K)+SUMMEWENN(A:A;"XYZ";M:M)

Es geht aber kürzer mit:
=SUMME(SUMMEWENN(A:A;"XYZ";INDIREKT({"D:D";"G:G";"K:K";"M:M"})))

Das funktioniert auch mit SUMMEWENNS (in Spalte C steht WF)
=SUMME(SUMMEWENNS(INDIREKT({"D:D";"G:G";"K:K";"M:M"});A:A;"XYZ";C:C;"WF"))


zusammenhängende Spalten werden bekannterweise so addiert:
=SUMMENPRODUKT((A1:A99="XYZ")*B1:M99)

bzw. mit WENN, falls in den XYZ-Zeilen auch Texte vorkommen:
{=SUMME(WENN(A1:A99="XYZ";B1:M99))}
oder die Suchbegriffsspalte nicht eine Spalte am Rand ist - z.B. Spalte C:
{=SUMME(WENN(C1:C99="XYZ";A1:M99))}
Der Suchbegriff darf dann logischerweise keine Zahl sein.